0
0 Comments

I am new to OpenStack and the whole cloud-world, also I don’t have any experience in setting up a server via terminal. (So please write a beginner-friendly answer :D) I did the following steps:

  1. I have setup OpenStack on an VM with Ubuntu 18.
  2. I made an instance with an cirros0.5.2 image
  3. I followed this tutorial to understand how to setup an application on OpenStack (they use wordpress)
  4. After I did the network setup like in the tutorial (setup a router, connect the private network to the public one, added floating IP to the instance) I wanted to ping the floating ip 172.24.4.188, but I receive ‘Request timeout for icmp_seq’.

Now I tried several things to fix it:

  1. I checked my Mac OS firewall, switched it off -> nothing changed
  2. I changed the security group rules liked this -> nothing changed
  3. I also tried to follow this here but the openstack commands like
    nova flavor-list
    in the terminal shows the error:
    ERROR (CommandError): You must provide a user name/id (via --os-username, --os-user-id, env[OS_USERNAME] or env[OS_USER_ID]) or an auth token (via --os-token)

My terminal skills are super poor, so I don’t really understand why I need to add a user here, when I can login to the dashboard. Would be great if someone could explain me how to debug this network issue and why I don’t receive an answer from my floating ip. THANK YOU!

Anonymous Asked question May 13, 2021